Not able to create Postman webhook's after publishing flow

I am trying to deploy flow on postman cloud via webhooks but it seems that webhooks are not able to getting created. The flow contains multiple APIs calls. Its integration flow, connecting multiple APIs to sync data between each other. While deploying flow on Postman cloud via webhooks getting below error.

Can someone please help what is the issue with webhooks? How to find the issue?

We’re looking into the error you reported. It could’ve been transient. Your webhook looks like it was created, did you get the error on trying to use the webhook or on clicking “publish”?

Yes, I am getting below error while trying to request on same webhook. I don’t know while creating webhooks the flow actually deployed on postman cloud or not that is also a question?

    "error": {
        "name": "NotFound",
        "message": "No active deployment was found",
        "details": {
            "uuid": "xxxxxxxx"

While we are investigating the issue, did you try to unpublish the flow (click the more menu ... next to Publish and select Unpublish). This should allow you to recreate the webhook.

One additional detail that will be useful for us, are you using the Postman App or browser?

Screenshot 2023-10-11 at 8.06.55 AM

Yes, I tried multiple time to unpublish and also tried to recreate it. Also duplicate the same flow and tried to create webhooks for the same. but it seems not working… I am doing this from both web app as well as desktop app to check its working or not… on Web app, after creating webhooks then I refresh the page the webhooks entry is not there its disappear from the webhooks section. So, I again create the webhooks but its not displaying webhook entry for that flow…

I feared this was the case. We are investigating and will keep you posted. Sorry you’re encountering this issue.

Ok… So, this is the known issue to not creating webhooks for the flow… Can you explain it little bit?
Also, Can you please suggest any workaround to for this? I need to invoke flow automatically and it seems not working without webhooks.

I do not know the root cause so I can’t explain what’s happening yet. We have not been able to reproduce and we are investigating further.

Hi @urvish-powerbi it seems that for some reason, our backend was not able to fetch the requests and collections used in this flow. It could have been an intermittent issue, but might be something more systemic. I will continue to debug this, but meanwhile could you try publishing your flow again?

Hi @iamsaswat, I did try… but its still not working. Flow Id “652a30411bc6380032f9777b” and Webhook url is as below…

@urvish-powerbi Did you get a toast message saying your flow was published successfully or did you see an error when you published? Reason I am asking is because I don’t see any errors on my end.

Calling the webhook will not work, unless you have one successful publish. The UI is bit misleading, we shall fix it soon.

HI @iamsaswat , Yes I got toast message that flow is published. but the webhook is not working. when I hit the webhook it says “active deployment not found” message… and when I refresh the page on browser the webhook section is empty…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.