Newman html reporter does not generate a report file

Newman itself is able to run my tests, but is not creating any html file of the output, and is not throwing any error. It just thinks for a few seconds, then does nothing

Steps taken:

  • Installed Node.js (node-v18.14.0-x64.msi)
  • npm install -g newman
  • npm install -g newman-reporter-html
  • npm install -g newman-reporter-htmlextra

All installed fine, no errors.

C:\Users\xxxxx>newman run "C:\Tools\Newman\collection.json" -e "C:\Tools\Newman\environment.json" -r

This much executes just fine. The tests run.

C:\Users\xxxxx>newman run "C:\Tools\Newman\collection.json" -e "C:\Tools\Newman\environment.json" -r html

But this does nothing. After a few seconds of nothing it displays an empty line:

C:\Users\xxxxx>

…and generates no folder and no file. Same thing if I try htmlextra instead of html.
I have tried this on an account that has full admin rights and on one that does not, same results.

This is similar to Newman report (html/html extra) not generating any output, but that thread did not have any replies.

Hey @david.accola

Can you raise an issue on the repo, please.

1 Like

Hi @david.accola

Just tried this using the same steps you listed and it appears to work for me…

newman

Have you tried specifying a specific output directory? For example; `

C:\Users\James>newman run “C:\Users\James\PMtest\NewmanTest.postman_collection.json” -e “C:\Users\James\PMtest\NewmanTestEnv.postman_environment.json” -r htmlextra --reporter-htmlextra-export “C:\temp\New folder”

This also works for me.

2 Likes

Ah, I see! It is generating a folder and file after all.

I had thought it generated the folder/file in the path the collection was located in by default for some reason, instead of generating in the current working directory. I reread the docs and all is well.

2 Likes