Last used directory when selecting a data file in Collection runner

Whenever I try to use a csv data file in the collection runner, I am always directed to one specific folder. I would like to use the last used folder so that I do not have to change to the folder I need every time I want to change the data.

I am using the desktop app:

image

I have tried to search on the Postman Settings, but I do not see any settings that can help.

Can anyone help with this?

Hey @german-chacon

I think I’m understanding what you mean but correct me if I’m not.

I don’t believe this is configurable and will always display the most recent directory that you were in, on your OS.

If you were to hit Select File choose a different directory and Cancel the file selection, the next to you hit Select File, it would go back to the most recent directory you were in.

This seems to be independent of Postman so if you were doing some other work in a directory and then going back to the app, it would go to that directory when selecting a runner data file.

I’ve had a look at the Github repo and I can’t see a feature request to make this a configurable setting, you could raise it here.

Hi @dannydainton . Thanks for your reply

Actually what you described is the expected behavior, but in my desktop app, it does not work.

It always goes to the same directory, no matter how many times I change the last directory used.

I tried re-installing the app and tried again, but it is always taking me to the same folder in my drive.

Any other thoughts you might have to get Postman to change to the last directory used?

Thanks

Which version are you using and on which platform (app or web) ?

I’m seeing that expected behaviour on the latest version :thinking:

@dannydainton I am using the desktop app Version 9.6.1

the web version works fine though

That’s strange, I’m not seeing that on my side. :thinking:

Could you raise an issue on our tracker, please?

If you can include a short recording of the behaviour, that will help the team to see what’s happening.

I have the same problem. Is there already raised an issue on the tracker for that?

@dannydainton I have created an issue with a small video on what is going on.

Thanks

1 Like