Inspect a webhook after sending a request

Hello,

I’m creating a Postman collection to test my company’s API. Sending requests works well.

After each received API call, the system sends a webhook, how can I receive/inspect this in Postman?

I tried to use https://webhook.site/ to manually see the webhooks and it works, but I would like to know if it is possible to receive the webhook payload on Postman directly

Thanks a lot for your time!

Cheers,
Nelson

Hi @n.morenogolubev,

One option you have is to run the Webhook through webhook.site and import the request into Postman.

  1. Find the request on webhook.site.
  2. Look for the Export As menu
    image
  3. Select curl.
  4. Select Import in the upper left-hand side of Postman.
  5. Select Paste Raw Text.
  6. Paste the curl command.
  7. Click the Import button.

Alternatively, if you’re looking to have a more real-time view of this, you can try this approach with the Postman Proxy and ngrok. With ngrok, you can create a tunnel between a public URL and your local computer. If you point this to the Postman Proxy, you can get your Webhook calls sent directly to Postman.

  1. Install ngrok (https://ngrok.com/download).
  2. Start the Postman Proxy (See: https://learning.postman.com/docs/postman/sending-api-requests/capturing-http-requests/#built-in-proxy)
  3. Start ngrok and point it to the proxy (By default, this will be ngrok http 5555.)
  4. Start making calls to the public URL exposed by ngrok. In your case, you’ll need to wire up this URL as the Webhook URL in your application.
  5. Depending on which settings you chose for your proxy, these requests will start showing up either in the Postman request history or as new requests in a previously selected Postman collection.

Ta-da!

Best,

Kevin

Hello @kevin.swiber,

Thanks a lot for your answer! It’s exactly was I was looking for, I feel really close to a solution here!

I did all the steps with ngrok, unfortunately, the webhooks are not reaching the forwarding URL

I tried several ports (5555, 80, 8080, 443) with no success. On the logs of the webhook service I can see “Info : {“erreur”:“Error 0 : Failed to connect to xxxxxx.ngrok.io port 443: Connection timed out”}”
The logs always mention port 443 or port 80

It seems very weird to me but it might be that the webhook service has blacklisted ngrok.io URLs… I’ll check with them tomorrow just in case

Cheers,
Nelson

PS. for some reason postman just crashes when trying to set up a proxy with port 8443

Hello guys! Have you succeeded in this? Could you please share your experience?
Thank you !