Imported collection not showing the associated prerequest script

Postman 7.31 for windows 64 doesnt import prequest script when JSON based postman collections are imported . If request which is dependent on prerequest script is triggered postman goes in infinite hang mode .

Hey @rakotkar

Welcome to the community! :trophy:

Can you provide some examples of what you’re seeing please? Where is the failure happening?

Is this being trigger when sending an individual request or with the collection Runner?

Could you walk through the steps that lead you to this point?

It’s hard to see what’s currently going on by that description alone. You’re need to expand of this in order for the community to offer a solution. .

I just followed this steps and checked the prerequest tab and I can see nothing being imported. Also ,while I fire my request I can see the postman hangs forever and I have to forcefully stop it.

The pre-request script is at the Collection Level and not in the individual requests.

From the Collection name on the left sidebar, select the 3 dots and then press Edit. That will show the collection level elements.

I don’t know what that particular collection does so for it to be timing out or hanging forever is a different problem.

Just ensure that you set all the required variables in the imported environment file - if that’s still not working you can open an issue of that person’s repo and I’m sure they will help you out.

Sure , I will check that but it suddenly started behaving this way , before 2 days it was working fine. Later on while I reinstalled and reimported the collections it was still the same . So I suspected , the issue might be with postman thing, as postman goes to a infinite hang state. Could you please guide me to postman logs on windows I can try to find something there

While I run the GET in the OCI_REST_INTIALIZATION , I get to see the following erros in the dev console

That’s a warning and not an error. :grin:

What do you see for that request in the Postman Console?

I get proper response for this. Do I need to check any settings on Windows . It suddenly started hanging and that’s why I am puzzled if its due to any of windows settings or any temp cache .So I tried reinstalling ,removing cache changing version of postman.but It still gets hanged.