Import function is not working as before

My question:
I have been working for several months on the documentation of some API’s with the Swashbuckle library with .NET6
The swagger.json is being generated programmatically and it was possible to show specific examples with desired values.
But since yesterday the import is not showing the examples that were being shown and the API’s structure is not grouping them as before and it is the same swagger.json that worked a few days ago.
I don’t know if the structure changed with this update but in swagger it does load the example in the RequestBody.

Details (like screenshots):
I show some examples how the grouping of API’s looked before


And the example was loaded in the Body in the post request

How I found the problem:
I found the problem when I was doing the import of a similar swagger.json and it is not grouping like the previous one, (I have not changed the structure of the endpoints)

I have already tried to load the same swagger.json and it does not show it as before, I don’t know if it has something to do with the new update or they updated the API’s/collection import service.

Hi @erickmar, could you share

  1. What Swagger version are you using?
  2. If possible, share the swagger file so we can try to reproduce it on our end. You can send it to

Hi !
Of course,

  1. The swagger version is

Swashbuckle.AspNetCore.Swagger version 6.5.0

And Swagger UI 3.x

  1. I will send the swagger.json by email.

Thank you very much!

Thanks for this info. We are looking into it on priority. I will keep this thread updated :man_bowing:

1 Like

Hi @erickmar, Is it a blocking issue for you at the moment? Were your workflows based on these groupings?


It’s not blocking me at the moment, but it’s a functionality that already existed and I don’t know if they changed the syntax for grouping or it won’t group them anymore. I would like to know because I have already presented these APIs with this bundle to the users who are going to use it.
Is there something wrong with the swagger.json?

Thanks for your answer.