Headers don't get added when POSTing a file as form-data

Hi, I’ve been using Postman almost every day for years now. A month ago I defined a request which uploads an image as form-data. It always worked as expected until this morning. Postman doesn’t generate the necessary headers anymore. I’ve tried every suggestion I could find on Stack Exchange and similar sites. Nothing works.

I installed the Chrome extension and that does work as expected.

Any idea what could be wrong?

Hey @bertenvdb,

Are you about to provide more context about the request, please?

An example image of the request and any environment details would help people get you a solution quicker. :slight_smile:

Thank you for your fast response :+1:

It’s a quite simple request. No environment variables, and I have 2 query params: a userId and a mediaTypeId which tells the backend what the image is for.


I just copy/pasted this path in the Chrome extension, then Body>Form-data and chose File as type and selected an image stored on my computer. That works in the extension but it doesn’t anymore in the desktop version.

If I debug the call I can see that when reuesting through the Chrome extension, the Content-Type header gets set to ‘multipart/form-dat’ including a boundary and the Content-Length header also gets set. When making the request using the desktop version both headers aren’t set.



Chrome extension