gRPC import path not working

I am trying to import a proto file and while one that has no import specified is fine, when I try to add the add import path, even if incorrect, postman keeps on complaining that it is not correct. Please see screenshot attached

image

anyone have any idea on this please?

Hey @db-tester! While adding the import path, you need to specify the path to the parent folder from which you are importing the proto file.

For example, given the following project structure, where root.proto contains the import statement import "x/y/z.proto", you need to add /my-app as the import path.

my-app/
โ”œโ”€ root.proto
โ”œโ”€ x/
โ”‚  โ”œโ”€ y/
โ”‚  โ”‚  โ”œโ”€ z.proto

In your case, adding the path to the parent folder of protos should do the trick!

@appurva.murawat so what you are saying there needs top be 2 import paths set? as for this I have tried the folder at different stages and all of them resulted in the same error

I am too facing this error in postman version mentioned below,

Version 10.13.5
UI Version: 10.13.5-ui-230424-1413
Desktop Platform Version: 10.13.0 (10.13.0)

Were you able to resolve it ? If yes, can you help me out here !!

@appurva21 I tried what you suggested but it isnโ€™t working same as what @db-tester mentioned. Can you please suggest something

Running into the same issues over here too.

same issue. any progress on it?

This is still happening, has there been a resolution on this?

Follow this reply to get clarity on how to specify the correct path when importing a proto file.
The video below demonstrates the process, make sure youโ€™ve updated your Postman app to version 10.24.1 or later.If youโ€™re still encountering the issue after updating, please let us know!

1 Like