GetPublicLink - UpdateLink Button remains greyed out

Hi All

I have a collection which I use to add/edit endpoints and also automate various tests within these endpoints. I then use the UpdateLink (from Get Public Link) button to update automation changes on Azure.

What I have noticed is that on occasion the “Update Link” button remains greyed out as “Fetching Link”. Result is that the changes are not updated on Azure

What could cause this? If I run the new or changed endpoints using the Postman Runner locally on my pc then all works fine with no errors, problem occurs when Updating the link.

What process is involved for a successful update to take place?

Kind regards

Hey @selwyn :wave: Welcome to the Postman Community :rocket:

Sorry to hear you are facing some issues with updating the sharable link for your collection.

The expected behaviour would be upon clicking the “Update Link” button, it turns to “Fetching Link” temporarily (for a few seconds) and then turns back to “Update Link”. But is this not what you are seeing?

  • Are you seeing this issue only for a specific collection or any collection?
  • Are you seeing the same behaviour on both desktop app and web dashboard (go.postman.co)?

I am looking forward to hearing back from you! :slightly_smiling_face:

Hi @taehoshino

Your description is correct, “Fetching Link” appears temporarily when it works,

On occasion “Fetching Link” is not temporary it remains “Fetching Link”. Let me give you an example…

I have one collection which contains many different endpoints running various test etc. I decide to add a new endpoint but the “new” endpoint is not actually new because all I am doing is testing a different scenario with different inputs but yes I am adding a new endpoint via “Add Request” in Postman.

What I find puzzling is that the “new” endpoint works fine when using the Postman Runner no errors, problem comes in when I add this new endpoint to my test collection and I wish to update the tests on Azure “Fetching Link” remains grey.

Could it be corruption in my existing test collection?

You aware of any logs I could look at ?

I have tried both the desktop app and web dashboard problem persists.

Thanks for your input.

Hey @selwyn

Could you provide some visual examples of what you’re seeing, please?

It’s the best way when describing different things you’re seeing in the UI :grinning_face_with_smiling_eyes:

1 Like

Hi @dannydainton @taehoshino

image

As you can see from the image Fetching Link remains greyed out.

Any ideas would be appreciated.

Thanks for sharing the screenshot @selwyn :pray:

Are you seeing this issue only for a specific collection or any collection?

Also could you tell me if you are using proxy/VPN/Firewall?

If the issue persists, please feel free to submit a support request from below link so that we can investigate the issue further :slightly_smiling_face:
https://support.postman.com/hc/en-us/requests/new

1 Like

Hello @taehoshino @dannydainton

Thank you for your reply.

After a few tests \ experiments I have managed to find the problem…

In the tests section I was using the old deprecated tests object which I removed and replaced with pm.test(). Update Link button works as expected.

What was the reason for deprecating the tests object?
Using the tests object in existing tests could this result in javascript memory problems when using newman runner?

Regards,
Selwyn

1 Like

Hey @selwyn :wave:

Glad to hear that the issue was resolved.

You mentioned you were using “tests” object - I am not aware of this, so would you please share a piece of your sample code where you use this object?

They are referring to this older tests syntax

1 Like

Hello @taehoshino @dannydainton

Sorry for only getting back to you now, more testing from my side revealed the following:

They grey UpdateLink button had nothing to do with me using the deprecated test object. I am still curious to know why the test object was deprecated could it be that maybe it was consuming too much resources?

Problem is that I am running low on either disk space and\or my license needs to be upgraded. As soon as I remove some of my tests then my UpdateLink button works as expected.

Thanks again for your suggestions

Thanks for getting back!
Glad to hear you can now use the Update Link button without any issue :tada:

Please do let me know if you have any other questions! Happy to help :smiley: