Debian Buster Installation

Tried installing postman via snapd, however the application never launches with no messages.


Hi @kramer9

Welcome to the community :wave:

I believe you have tried installing via: May I know if you are receiving any error message while launching the application? Screenshot of the same would help.

Thats where I am stuck, no errors of any type. Can you recommend how to put it into debug mode?

Here is all that happens when I try to launch it via command prompt

user@debian:~$ postman

@kramer9 That’s strange! Would it be possible for you uninstall this version completely and reinstall the latest version (v.7.23.0)? Let us know if the issue persists.

Hi Raj

Did a reinstall with no different results:

snarf@debian:~$ sudo snap remove postman
postman removed
snarf@debian:~$ sudo snap install postman
postman 7.23.0 from Postman, Inc. (postman-inc✓) installed
snarf@debian:~$ postman
1 Like

@kramer9 Thanks for the update!

Would it be possible for you to submit a ticket from the below link and we will check on this further:

Done - Thank you for your help! Id #50578

1 Like

Posting the fix for all - there is a bug with the release. The resolution was to download 7.23 and reinstall. I lost my collections - no idea why, so I am not sure if there is a resolution there.

Steps to fix

sudo rm -rf /opt/Postman/
sudo tar -xvf Postman-Postman-linux-x64-7.23.0.tar.gz  -C /opt/
sudo ln -sf /opt/Postman/app/Postman /usr/bin/postman
nano ~/.local/share/applications/postman.desktop
1 Like

For anyone facing similar issue - If you have using signed in to Postman account then all of your collections are synced to the web dashboard. Navigating to the below link and sharing it back should resolve this else a simple sign-out & sign-in should populate all the collections back.