Coorporate firewall and proxy trouble

Hello everybody, huge newbie here

I am working behind a coorporate firewall and are receiving boring errors in Newman when the same calls works just fine when i go to settings and disable ssl verification in Postman:
newman run{{collection_uid}}?apikey={{api_key}}

The error i get is:
‘error: unable to get local issuer certificate’

You’ve all seen it before. I have tried:

  • adding --insecure / -k
  • downloading the certificate in .cer format and adding --ssl-client-cert {{certificate.cer}}
  • converted it to .cert format and tried again

After some looking, i found the variables HTTP_PROXY, HTTPS_PROXY and NO_PROXY. Messing around with those (assigning them with just *) gives the error:
tunneling socket could not be established, statusCode=400

Is this a step back or forward? I haven’t given you guys much to go on, but is it impossible to call that address through Newman if it needs authorization or do i need to mess around a little more with it?

If its not possible, is uploading our collections and environments to our local github manually for Jenkins to call automatically a good solution or have i missed something better? Because that could be a bit tiresome to version control ourselves :frowning:

Thank you guys so much for reading :slight_smile: