Newman error: connect ETIMEDOUT

Hi all,

When I try to run a collection with newman from the command line, it is giving me timeout.
If I run it from the postman, it’s okay.
Why could it be?

C:\Users>newman run
error: connect ETIMEDOUT XX.XX.XX.XX:XXX

Thanks and regards


In cmd, if I run the command line:
set HTTPS_proxy = myuser: mypassword @ ipoftheproxy: portoftheproxy
set HTTP_proxy = myuser: mypassword @ ipoftheproxy: portoftheproxy
And then I execute newman run …
Works! Go!
I understand then that I have some error in the proxy … but I do not know how to solve it.

Hi @pablovok,

The Postman app and Newman CLI are independent of each other, so you would have to set the proxy in the command line itself, it doesn’t sound like you have an error in the proxy since it seems to be working on the app as well.

Hi @aamir.ahmed,
Add the command line and go … but if I run it from jenkins I still have the same error. :sob:

Hi @aamir.ahmed,
I had not rebooted jenkins, that’s why I was not … :sweat_smile: