Cookies not being saved after OAuth2 authentication

Hello,

I recently updated my desktop client to version 8.0.3 from 7.36.0.

When I was using version 7.36.0, cookies would be saved after receiving an access token from the IPD we use for authentication using OAuth 2.0. There would be numerous time where I would need to change the user login for separate testing. So I would open up the cookies manager and delete the authentication cookies so I can get a new access token using the new user account.

However, I’m not seeing any cookies being saved after I authenticate using version 8.0.3. I open up the cookies manager and nothing would be there. The only way I can clear everything is to stop the client and restart it again, then I would be able to receive an access token using the new user account. Otherwise it just refreshes the access token for the current user account.

Is there a way for Postman to save these authentication cookies in this new version? If so, how do I set it up, because I’m not seeing anything in the settings that seems to be related to authentication cookies.

Thanks

1 Like

I’m just chiming to say I’m seeing exactly the same issue after upgrading to Postman 8.x.

I added a comment to an issue submitted yesterday regarding OAuth authentication and cookies.

Hey @psavage_jtv @alexayers!

We have fixed this issue with the latest release of Postman App (v8.0.5). Please checkout this comment on the related Github issue for more information :slightly_smiling_face:

2 Likes

Thank you! The fix worked like a champ. I’ve also marked your comment as the solution.

Hello @appurva.murawat , I do see an issue in clearing session cookies using postman version 8.03. I tried upgrading to 8.0.5, but still it is not clearing the session cookies. Pls note the previous version of postman works. Scripts started failing after updating the version to 8.0.3. Appreciate your help & response.

I’m facing the problem exactly as described by @psavage_jtv in the question title “Cookies not being saved after OAuth2 authentication”.

After update my Postman to v8.0.5 I tried to send a saved request in a previous version ( v7.36.4) just after authenticate using OAuth2, but haven’t success. Even clearing the cookies in the new button “Clear cookies” and reauthenticating, I noted that some cookies are not being saved so the request fails.

@andreas.adelino I’ve noticed that the cookies are now showing up in the cookie jar manager after updating to 8.0.6 today. Try updating to that version and see if that helps with your issue.

1 Like