Cookie manager auto adding secure flag causing postman to fail for local env

My question:
I’m working with an API that generates a cookie upon login and until recently this worked without fail. As of today (upon updating postman) the cookie created includes the secure tag which means the cookie is unable to work with localhost. When I delete the secure tag everything works as intended but as soon as I hit an endpoint without the secure tag it auto adds itself back. Has anyone seen this before and if so do you have a suggestion or workaround?

Details (like screenshots):

Postman version was 9.5.0 and is now 9.15.2.

How I found the problem:
I updated postman and went to test some endpoints. This is not impacting interacting with environments outside of the local one.

I’ve already tried:
I tried rolling back to postman 9.5.0 via another machine but the problem seems to exist there now too. I’ve checked all my settings and ensured that nothing is different. I’ve also tried both deleting the secure flag and setting it equal to false (though doesn’t even save).

edit: tried adding http before the localhost port but it still fails