Collection Variable Bugs


I am having various bugs with Collection Variables and was wondering if anyone else is having similar issues. I am running Postman on Ubuntu Linux.

Version 7.36.0
linux 5.4.0-53-generic / x64

  1. I set a request Header to a Collection Variable. This works as expected. Later i come back and the variables are marked red and when hovered over they say unresolved. I paste the exact same variable name text into the curly braces again and it now says resolved even though nothing has changed.

  2. When i run a request individually (that is part of a collection) it runs as expected. When i run the request as part of a full collection of requests the Collection Variable Header value is not sent. Instead Postman sends the variable placeholder as the string value e.g. {{variableName}} is sent as a value of “{{variableName}}” instead of the value assigned to that variable.

Any ideas? Maybe the Mac version will be more stable?


Could you add some screenshots, maybe share a small collection where you see this problem? It would help narrow-down the issue.