Cli-reporter-options in node program

I want to supress assertions in newman execution from node. But there is no way to make it work.
My code is like this:

	            reporters: ['cli','html','json'],
	            reporter: {
	            	'cli': {
	            			'no-assertions': true 

Does anyone knows what I have wrong?

Try camelCase for the parameter name “noAssertions”

Wonderful !! Thanks a lot

Was having the same issue regarding specifying CLI Reporter Options and the camelCase seems to be working for no-banner and no-failures, but no-assertions does not seem to work. If I call newman outside of node and specify “–reporter-cli-no-assertions” it works fine. I am using:

Node: V8.10.0
Newman V4.1.0

Here is my config:
reporters: [‘cli’],
reporter: {
‘cli’: {
‘noBanner’: true,
‘noAssertions’: true,
‘noFailures’: true


UPDATE! - While troubleshooting I had upgraded to Newman V4.1.0 and realized I ran the test outside of node before I had upgraded. Re-ran the command line and it no longer worked. Downgraded back to Newman V3.9.3 and it now works on both the command line and camelCase calling from node.

"–reporter-cli-no-assertions” is still in the docs, was it deprecated or is it a bug in V4.1.0?


That’s odd, following options are working fine for me:

   collection: 'collection.json',
   reporters: ['cli'],
   reporter: {
       cli: {
           noBanner: true,
           noAssertions: true,
           noFailures: true

Can you try upgrading back to v4.1.0 and check if the issue persists with the above options?
Also, share your script used to run Newman.