Cannot complete very first Bootcamp lesson

My question:
I am unable to complete even the very first Bootcamp lesson, “Design an API in a minute”. The popups disappear when selecting an environment and do not return.

Details (like screenshots):
Here is a video screengrab of the occurrence: Dropbox - Postman_z4obZSqY17.mp4 - Simplify your life

And here is a screenshot of the moment where the lesson fails:

Once I click on the dropdown, the lesson bubble disappears so I cannot continue.

How I found the problem:
Just by trying to go through the lesson as designed.

I’ve already tried:
Attempting the lesson three or four times. Same result exactly.

Hi @postmanmcgee - thanks for reporting this bug. I just tried it, and see the same thing. Can you confirm when you click Bootcamp (bottom right) > Designing and Mocking APIs > Design an API in a minute > Resume - do you start at the first step again still?

Hey, @joyce, thanks for confirming.

Indeed, going back to the list of Bootcamp lessons and choosing to “Resume” the lesson just starts it over from the beginning. Likewise when choosing the “Continue learning” link in the bottom-right of the UI when it is changed from “Bootcamp”.

Ok - the team is working on this fix. In the meantime, if you’re eager to learn more about the API builder, here’s a more in-depth video: API Builder | The Exploratory - YouTube

I finally had some time to go back and try this bootcamp lesson again. It now appears to work! Thank you, Joyce!

Nice! there’s no shortage of learning resources, so let me know if any other lessons pique your interest.

Just found the Bootcamp button. Started the first lesson but cannot complete it. I tried the create a mock server section like 5 times but it just wont complete. The last %status I can see is 38% and then it changes to continue learning but when clicked it just starts over making a server again.

same here, just started but the guide disappears sometimes while other times I get an error message

I’m trying the Designing and Mocking APIs bootcamp, the one called “Design an API in a Minute”. I only get to the part where I select “Mock Server”. Then the guide goes away, and when I restart, it goes back to the beginning.