API Testing and Automation Training

My collection:
https://www.getpostman.com/collections/62aa13f89097541954d1

When I run Request 5 - Complete Training, I get the following failure in the response body:
"No script setting request execution order (request 4)"

I do have the following line at the bottom of the tests for my 4th request, which I thought would satisfy this check:

//Step 4: Automate your test runs
postman.setNextRequest(null);

Any help would be greatly appreciated!

Hi @jeffdt! Your collection link passes for me when I run the Complete training request, could you try again?

1 Like

Works for me now too! I’ve been trying it off and on all day (including several times right before I posted this) so that’s a surprise. But hey, I’ll take it :grin: Thanks!

Edit: Actually, I did click “Update link” in the “Share Collection” menu item. I’m wondering if it was just out of sync and that fixed it.

1 Like

Yes that’s likely been it, it’s basically a snapshot, definitely not the most intuitive flow but it does the job…! :sweat_smile:

It makes total sense now in retrospect though! I thought it didn’t do anything when I clicked it because the URL itself didn’t change, but then, it wouldn’t be a very useful as a link if it changed every time I updated something :smile: Maybe a slight change to terminology would help, something like “sync changes”. Thanks Sue!

It’s definitely a Postman quirk, we basically use it for training because it’s handy for checking completion, but hopefully will come up with something a little more intuitive one of these days lol. :crossed_fingers:

1 Like