API-call from postman to device using an AD user is failing

I am trying to run an API-call from postman to my flex-appliance using an AD user . I am getting an error as below:

However, When i am trying to login to the flex-appliance using the same AD username and password then i am able to do so.

At the same time , I am able to run the API call to my flex-appliance using a local user created on flex-appliance.

How can i run the same API call with my AD authenticated user also ?

Thanks !!

Do you have an link to the API documentation?

I donโ€™t know anything about your environment, but I would try the SamAccountName and perhaps the email address as the username (instead of the AD username field).

EDIT: Just noticed that you have the request as raw\Text instead of raw\JSON, which would be the first thing to try.

Hello Mike,

Thanks for your reply. I sorted out the issue and its now working from me.
I was using AD\ But when i made the API-request to pull all the user details from local user then i noticed that the AD username appeared in the response as AD\.
I tried with AD\ and it worked.

Thanks for reply though . Have a good day !!

1 Like

Yes, domain\username is how some of our (older) apps work as well.

Nearly everything now is the email address, and most are now using Azure for authentication.

Glad youโ€™ve got it working.

Hello Mike,

I already tried with the full email-address like abc@test.com earlier but it did not work. This is why i posted my query as a help-seeker here and i am glad to notice that we actually have some help available here :slight_smile:

I was using doamin\username (single bacslash after domain)

but the issue got fixed when i started using domain\username
(Double backslash after domain)

I donโ€™t know why double backslash is not getting visible here . Strange !!

Double back slash. Fair play, as Iโ€™ve never seen that before.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.