Version 8.4.0 " import WSDL specification"

I was very happy to read the latest release notes for version 8.4.0

Release Notes | Postman

Importing WSDL (and viewing PDF as well ) would be great. I went for what seemed obvious and pasted the WSDL below into Import > Link

But it threw an error:
Error while importing WSDL: Cannot read property ‘@_targetNamespace’ of undefined

A basic guide on WSDL in Postman would be very helpful. I have not found anything on the subject except the one mention in the 8.4.0 release notes.


in the app version, same wsdl throws “Error while importing: format not recognized”

I find same wsdl throws,+1

I tried importing my own wsdl, but a popover error appeared saying: “Error while importing WSDL: Can not get port type from object”. This error is not that descriptive, as there are portTypes defined in the wsdl. Which object? Why can’t I read back the error in case I missed the alert that disappears after a while?

Same error shows here:

A little help in debugging would be welcome

I experience the exact same thing.

I am unexperienced with WSDLs, but in my case I have narrowed it down to having something to do with with namespaces.

In my WSDL, when the types tag has a namespace <wsdl:types>...</wsdl:types>, Postman crashes with the error Cannot read property ‘@_targetNamespace’ of undefined.

Removing the namespace from <wsdl:types><types> imports the WSDL, but types do not work. Same result if the tag is just deleted.

Unfortunately I cannot share the WSDL I am working with.

@nkpg-vladde Can you provide a representative sample WSDL document that illustrates this problem?

@abhijit I can reliably reproduce what I explained with the original poster’s link:

  1. Download the file
  2. Import in Postman
  3. See error: Error while importing WSDL: Cannot read property '@_targetNamespace' of undefined
  4. Open the file, and replace any occurance of wsdl:types with types
  5. Import the file again
  6. “Successfully” imported the WSDL (although, missing types)

I am using Postman v8.5.1

I cut up the original poster’s WSDL into the smallest possible example I could while still getting the error

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions xmlns:wsdl="" xmlns:xsd="">

Importing this produces the error Error while importing WSDL: Cannot read property '@_targetNamespace' of undefined

I do not know the internals of Postman, but I could make the error go away by doing either of

  • Remove the wsdl: from the types tag <wsdl:types> and </wsdl:types>
  • Remove <foo></foo> on line 4
    • <foo></foo> could be anything, main emphasis on if any tags are in there, it fails.


Seems like file you mentioned has namespace defined as xsd meanwhile the usage in <types> is using xs prefix. We are working on fix for this and it will be fixed soon, meanwhile you can make this change of using same prefix in file and it should work.


Can you share WSDL definition or sample file? Also make sure that you are using latest app as older version will not support WSDL imports and will throw similar error.

@magnus_r @friso-volksbank @nkpg-vladde

Your issues should be solved with Postman App v8.6.0

1 Like

Hello @vishalkumar.shingala and @abhijit
Any chance you could look at other WSDL files that do not yet work, even on 8.6.0 ?

Hope it’s going to be fixed soon!

1 Like