Test pass on Postman but fails on Jenkins - reason "expected string to deeply eql integer

Your question may already have an answer on the community forum. Please search for related topics, and then read through the guidelines before creating a new topic.

Here’s an outline with best practices for making your inquiry.

My question:
Good day
I’ve been running those tests for few months already and they were passing
Since I’ve updated to latest version I have tests passing in Postman but failing in Jenkins
Reason - Jenkins gives Assertion error - expected ‘123456’ to deeply equal 123456 but test is passing in Postman
I did a try and used JSON.stringify function on this parameter - now
the test is passing in Jenkins but fails in Postman
Maybe someone else also experiences same problem
In general is it possible to make test pass test based only on value of parameter and ignore string/integer differences
Details (like screenshots):
test failing in Jenkins

same test passing in postman

changing parameters in postman using JSON.stringify - result test pass in Jenkins but fails in Postman

Same result if I use parseInt function for other side

How I found the problem:

I’ve already tried: