SOLVED: Localhost:4000 -> ERR_CONNECTION_REFUSED in Team workspace

IF you try an API endpoint, AND Postman reports that it cannot connect to localhost:4000, AND you’re using the free version of Postman, THEN the ECCONNREFUSED result may be because you’ve exhausted a free Team workspace’s quota.

For Linux Mint 20, although I don’t believe that matters.

1. I created a workspace without paying attention to whether it was a Team or Personal workspace.

2. I was confused why Postman returned “connection refused” when as part of a GET it attempted to access localhost:4000.

3. I then tried python -m http.server 4000. (That syntax for Python 3. Python 2 has a different syntax.)

I could then use any web browser to access localhost:4000. So the problem wasn’t in the operating system or in the computer’s network configuration.

4. After a few missteps I realized that I had unintentionally created a free Team workspace AND that Team Workspace’s quota had been exceeded.

5. I created a Personal workspace and repeated the GET operation that had produced the connection refused error. In the Personal workspace the operation succeeded.

SO: If you’re using the free version of Postman, and you receive “connection refused” errors, then check whether you’re using a Personal or Team workspace. The problem may not have anything to do with your computer or its network configuration. It may instead be that you’ve used up your free Team workspace’s quota.

Cheers & hope this helps,
RBV
SFO

Hey @rbvandyke

The plan type wouldn’t restrict or stop the ability to make requests in any Workspace.

The free version does have limits but these are on the shared history and shared requests. Once you get close to and reach these limits you will be informed by several UI based prompts. The collections will be archived after a period of time if the limits are still breached.

There could be a number of different reasons for that particular request to fail but I don’t believe it would have anything to do with the plan you may have been on.

Hey @dannydainton:

Not the Plan, perhaps, but the Workspace. All I can do is reiterate my experience as follows.

1. Made various attempts to remediate Postman’s “can’t access localhost:4000” messages. Along the way, and as described in my original post, I used a Python web server to verify that my computer / operating system could access localhost:4000.

2. In response to Postman telling me my Team subscription was oversubscribed I created a Personal workspace, then imported the same JSON with which I had been having problems.

3. In Personal workspace, that which had not worked would work.

As I said, perhaps not the plan but I can but conclude that the type of Workspace was at the root of my problem…

Cheers,
RBV
SFO

Do you have any examples where you saw this message from Postman?

Team subscription was oversubscribed

Just wanted to clarify that notification.

The type of Workspace wouldn’t have any bearing on the requests made within them - there might have been a stored cookie or a certificate issue then solved itself by Importing the Collection into a new Workspace.

Are you able to still recreate the issue now?

I have tried to provide useful information to other Postman users who encounter the problem I described. I don’t have time to reinstantiate a Team workspace simply to prove that I experienced the problem.

If my experience as described helps a Postman user, great. Beyond that I’m done…

That’s fair. Thank you for taking the time to share your thoughts. :trophy:

I just wanted to clarify that the plan you’re on or the type of Workspace that you’re using wouldn’t impact the ability to make requests in any way.

I suspect there was a different root cause to the problem that appeared to rectify itself, when you created a brand new request, which on this occasion happened to be in a personal workspace.