Saved Request is automatically adding an "=" to the end of the request URL

No luck digging through documentation and support for an answer to this, so I’m asking for help.

Send the following GET request:

Looking at the Postman Console, you’ll see the request is

Now, save that request in Postman

And send the saved request.

Looking at the Postman Console, you’ll see the request is

The saved request is automatically adding the equals sign (=).

I get that it’s imposing the query parameter’s value, but this breaks a third-party API I’m working with.

Unfortunately I don’t have control of the third-party API and I’d like to store all the requests into a Postman Collection.


1 Like

I think you are running into a similar issue that I’m facing (Bug: Request URI mutation when saving). I’ve resorted to saving the request and then copying over all the parameters into a new ‘unsaved’ request when I need to use it.

I’ve been playing around with the pre-request scripts a bit and I think you might be able to resolve this issue by passing in the tail value (test) as a string stored in a variable by the prerequest script.

That sounds oddly familiar. I’ve been doing the same “copy & paste” method for now, but it’s a B when you have to copy a bunch of stuff (body, authentication, etc.)

I’ll continue to monitor your thread as well to see if this gets resolved.

Thanks for the heads up!


I tried this with our latest version 6.0.9 and couldn’t reproduce this. Could you give this another try with the latest version?

Hi Kamalakannan,

I tried with the latest version and it doesn’t happen anymore.

Thank you,

1 Like

Just tried with v6.0.9 and it cannot reproduce. It is resolved. Thank you!

This problem still exists in version 10.23: I have multiple query parameters of which I only use one at a time. When I uncheck one and check another, a “=” is automatically added, invalidating the request.