PS3838 : Could not get any response


I give Pinnacle API a try with Postman.
I use website which belongs to Pinnacle and is said to be the same API

I tested with success calls like login, get sports etc

Then i tried calls like get fixtures https://

and as a result i get :
Could not get any response
There was an error connecting to https://
Why this might have happened:

  • The server couldn’t send a response: Ensure that the backend is working properly
  • Self-signed SSL certificates are being blocked: Fix this by turning off ‘SSL certificate verification’ in Settings > General
  • Proxy configured incorrectly Ensure that proxy is configured correctly in Settings > Proxy
  • Request timeout: Change request timeout in Settings > General

Apparently it’s not about :

  • server response, self-signed ssl or proxy configuration as calls like login or get sports are working
  • timeout as my setting is to never timeout

Does anyone has an experience with that or an idea ?
I’m using Win10 Pro upto date and Postman 7.2.3
I uplodaed the screenshot of the console

Thanks in advance

Hey @Kynao

It looks like you have a gap between the https:// and api in the URL. This is causing that whitespace to be encoded and adding /%20 to the URL.

When removing that space does it do the same thing? Are you using an environment variable in that part of the request?

1 Like

Hell, i’m stupid, i looked at the console, saw the %20 in the url, i was going to see that and then my brain split on another subject before i did the verification…

Thanks you dannydainton, it works now.
Where can i buy a brain?

1 Like

Anyway Pinnacle provides 2 repositories here :

The one i’m trying to use ie api documentation

And the swagger documenation
Is there a way to directly import the swagger from there into Postman?

Glad you got it working!! :trophy:

You should be able to grab those yaml files locally and then import them into Postman using the Import feature, at the top left of the app.

1 Like

Great, thank you Danny, i will look into this good news in a few hours.

Thank you Danny, it worked as well

1 Like