"Could not get any response" Error: ESOCKETTIMEDOUT

All of my APIs are unreachable through Postman all of a sudden. I setup a quick test for the xkcd.com public api (http://xkcd.com/info.0.json) and I get the same thing. Console shows Error: ESOCKETTIMEDOUT. Bringing up that xkcd.com in a browser works fine so I don’t believe it’s a network issue. Postman version is Version 7.8.0.

Note the odd “There was an error connecting to .”

Could not get any response

There was an error connecting to .

Why this might have happened:

  • The server couldn’t send a response:

Ensure that the backend is working properly

  • Self-signed SSL certificates are being blocked:

Fix this by turning off ‘SSL certificate verification’ in Settings > General

  • Proxy configured incorrectly

Ensure that proxy is configured correctly in Settings > Proxy

  • Request timeout:

Change request timeout in Settings > General

@steve4: Did you get this to work? I’m getting the same issue.

Hi @steve4 @bipinkrishna15 - I was able to access the public API and would recommend you check if the proxy settings are configured rightly. Below is the screenshot for reference:

It was an intermediate certificate error. Chrome, Firefox and Edge all indicated the certificate was fine, but when I tried curl from a command prompt it gave a warning about a bad certificate chain. I’m guessing Postman is built off of curl so that was the reason. I reissued the certificate and reinstalled the intermediate certificates and the problem was solved.

1 Like