Previously working CSv Import file is not working anymore, please help

Describe the bug
I can’t seem to find an answer to this, so posting a new issue …sorry if it is already posted.

I am Importing a CSV file, which is correctly formatted and has previously worked with a 200 ok response. However, when i run it now it is failing and I am getting a 502 bad gateway message

To Reproduce
Here is my call

Here is sample csv Data

When I run this in the Collection runner below is my response

< !DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Strict//EN”” >
< html xmlns = “” >
< head >
< meta http - equiv = “Content-Type”
content = “text/html; charset=iso-8859-1” / >
< title > 502 - Web server received an invalid response
while acting as a gateway or proxy server. < /title> < style type = “text/css” >
body {
margin: 0;font - size: .7e m;font - family: Verdana,
sans - serif;background: #EEEEEE;
fieldset {
padding: 0 15 px 10 px 15 px;
h1 {
font - size: 2.4e m;
margin: 0;
color: #FFF;
h2 {
font - size: 1.7e m;
margin: 0;
color: #CC0000;
h3 {
font - size: 1.2e m;
margin: 10 px 0 0 0;
color: #000000;}

header {

        width: 96 % ;margin: 0 0 0 0;padding: 6 px 2 % 6 px 2 % ;font - family: "trebuchet MS",
        sans - serif;color: #FFF;
        background - color: #555555;}

content {

                margin: 0 0 0 2 % ;position: relative;
            .content - container {
                background: #FFF;width: 96 % ;margin - top: 8 px;padding: 10 px;position: relative;
            < /style> < /head> < body >
            < div id = "header" > < h1 > Server Error < /h1></div >
            < div id = "content" >
            < div class = "content-container" > < fieldset >
            < h2 > 502 - Web server received an invalid response
        while acting as a gateway or proxy server. < /h2> < h3 > There is a problem with the page you are looking
        and it cannot be displayed.When the Web server(
            while acting as a gateway or proxy) contacted the upstream content server,
        it received an invalid response from the content server. < /h3> < /fieldset></div >
        < /div> < /body> < /html>

any help would be much appreciated


Hi @JohnF75, this most likely looks like maybe the service is down / could be a DNS related issue.
Since it’s giving a 502 - Follow this link to read about 502 bad gateway error.

I highly doubt it’s related to CSV, check the URL that you’re hitting and also the status of the service.

Hey sivcan

I can post a single entry to the same call without any issues … the issue is when i use a csv file to enter multiple entries


There’s a possibility that the CSV data has some special characters (maybe /r or /n) that might be causing the issue,
After selecting the file in collection runner, can you verify the file by clicking ‘preview’ button?

Also, can you open Postman Console and verify your network calls as they go?
Check the data where it’s breaking, see the request data - I am sure you’ll be able to triage the incorrect parts of the request since it’ll be different from the correct request data.

When this happened to me, the first thing I thought to was to restart my machine.
Of course a sharper answer can allow a quicker result.
I wished to avoid searching.
If you get a correct result with a single record opposed to a collection, then carefully verify the variables types.

The Preview comes back perfect for me …which is the baffling thing

I’m using the postman console…however when i use it, Postman crashes on me everytime