Postman showing "sending request" but does not do anything

I was using postman on my desktop and it was working fine but suddenly after creating a new request it stoped working.
When I try to send request it just shows me “sending request” message but does not do anything.
I tried it on browser and it gave me the following error:
GET http://localhost:5000/api/user/all-users
Error: connect ECONNREFUSED 127.0.0.1:5000
Network
Request Headers
User-Agent: PostmanRuntime/7.33.0
Accept: /
Cache-Control: no-cache
Postman-Token: 3212aa03-1b2b-478e-84dc-af98f8d6fa96
Host: localhost:5000
Accept-Encoding: gzip, deflate, br
Connection: keep-alive shown this error when trying to click on postman

Hey @flight-administrato9 !

So the ECONNREFUSED error message typically means that a connection attempt was refused by the target machine. This can happen for various reasons when trying to connect to a local server or service.

  1. Server Status: Ensure that the server running on localhost:5000 is active and listening for incoming connections. If the server crashed or was stopped, you’d encounter this issue. You may need to restart it.
  2. Firewall or Security Software: Sometimes, firewall or security software can block certain ports. Ensure that your firewall is not blocking port 5000 or the application running on that port.
  3. Binding Address: Some servers allow configuration of which IP they bind to. If the server is bound only to a specific IP address (e.g., 192.168.1.x), it might not accept connections on 127.0.0.1. Check the server’s binding settings.
  4. Proxy Settings in Postman: If you have configured a proxy in Postman, it might interfere with local addresses. Go to Postman settings and ensure that you’ve excluded localhost and 127.0.0.1 from the proxy settings, or disable the proxy to see if that resolves the issue.
  5. Hosts File: Check your system’s hosts file to ensure there’s no incorrect entry for localhost. The default should be 127.0.0.1 localhost.
  6. Update Postman: Ensure you’re using the latest version of Postman. Outdated versions might have issues that are resolved in newer releases. The error message indicates you’re using PostmanRuntime/7.33.0. Check if there’s an update available.
  7. Network Issues: If you’re running the server in a containerized environment (like Docker) or through a virtual machine, ensure that the network settings allow for communication between your main OS and the container/VM.
  8. Logs & Errors: Check the server logs for any errors or warnings. The server might provide hints about why it’s refusing connections.
  9. Browser vs. Desktop App: If it’s working in one environment (like a browser) but not another (the Postman app), it might be due to specific settings or network configurations unique to that environment.
  10. Restart Postman & Your Machine: Sometimes, simply restarting the Postman app or your entire machine can resolve transient issues.

Hope this helps! Feel free to reach out if you have any other questions or concerns. :slight_smile:

Facing the same problem as addressed above, I have already restarted my machine even tried reinstalling Postman. its still working on requests that I had been using on my previous project but not working on new requests for my new Project.

leaving this here, for anyone in the future if the error occurs just logout of postman and clear local data, this worked for me hope it works for you too…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.