Postman returns "501 Not Implemented" Error when connecting

Hello,

I am using this tool GitHub - leonreucher/powerpoint-remote-websocket: VSTO PowerPoint plugin to remote control the SlideShow using a WebSocket connection to create a websocket for powerpoint in order to be able to control the powerpoint presentation through the network, although the tool is intended to be used with bitfocus companion the author states that you should be able to easily use it independently.

After installing the tool, it works flawlessly with bitfocus companion but when I try to use postman or wscat to send commands I get a “501 Not Implemented” Error.

Steps I took to get the error:

Install Postman Desktop
File → New → Websocket
Entered ws://ipaddr:80
in the message I typed
{
“action”: “next”
}

Troubleshooting Steps I took:

  • I tried using the Bitfocus Companion Module created by the author and it worked flawlessly.
  • I tried using the generic websocket module in Companion and wscat and it spat out the same error.

Any help is appreciated!