Postman fails on Manjaro Linux

Here’s an outline with best practices for making your inquiry.

My question:
A GET command is correctly processed with the Windows 10 app but miserably fails on a Linux machine. How can I troubleshoot the strange behavior? I’ve tried to tweak the command as far as I could but to no avail and I’m not very familiar with Wireshark, so I’m left with no clue. So guys, what do you advise to catch the Linux vs Windows difference?

Details (like screenshots):
Not working on the Linux machine right now…

How I found the problem:
Spending hours on the Linux machine! :grin:

I’ve already tried:

  • I have installed the latest available version on a Manjaro Linux machine, using the snap method from the AUR repository. No problem during installation, Postman launches fine.
  • However, when connecting to the target API (access control device), I just cannot step over the first Authenticate (GET mydevice/api/login command, body = JSON embedding login + password): the tool always return a weird “timeout” error, although there’s no real timeout triggered by the device.
  • On the same machine, accessing the device’s GUI works fine and I can properly authenticate. There, the browser is basically sending the exact same command I’m trying to cast with Postman.
  • If I change the GET command to a POST command, which should normally fail, Postman correctly sends the POST command and display the error message returned by the device (HTTP 405). This proves it’s able to send commands through the network to the device.
  • Grabbed the latest Windows version (v9.3.1) and installed on a Win10 machine, on the same network (I used the same network cable to be sure): the Authenticate command is properly processed and Postman returns the expected authentication token!

Thanks in advance for any help!

Hi there!

Any clue to get my Linux Postman working as expected?

Thanks in advance for any help!