Postman CLI - Error While Loading Package

Attempting to use Postman CLI to run a collection which uses a package in a post-request script. Logged into CLI with API Key. Collection being referenced by ID. Environment being referenced by ID. Folders being referenced by Name. Receiving error below. Request/script runs fine when running via Postman UI.

postman login --with-api-key [apikey]
postman collection run [collectionid] --environment [environmentid] -i “folder1” -i “folder2”

  1. Error
    Error while loading package ‘@teamname/package-name’: Something went wrong while fetching the package.
    at test-script
    inside “FolderName / RequestName”
    The system cannot find the path specified.

Windows 10
Postman CLI v1.9.0
Postman v11.2.13

Hey @AndrewFreyman :wave:

Welcome to the Postman community :postman:

Do you get the same issue without referencing the folders in the command or using the folder ids instead of the names?

I tried both no folders and also referencing the folders using IDs and both are yielding the same error message.

1 Like

Hi @AndrewFreyman,

You are not alone. I see the error with Windows 10 and Postman CLI 1.9.0 (the latest version).

I’ve raised a support ticket and it’s been investigated currently, Hopefully, they can resolve it soon and we will both benefit from it.

The Package Libray is such a cool feature, it will make a big difference for us as we use lots of additional functions, and having them held centrally will reduce the duplicate code we currently have in each collection.

Cheers
Paul.

1 Like

Hey @cruxto :wave:

Do you have an issue number or link to the one you raised, please?

Are you both on certain Postman plans?

Hi @danny-dainton,

The Issue number is 202477.

I’m on a Postman Pro plan.

Cheers
Paul.

1 Like

I am also on Postman Professional. Thanks for any help with this! A fix would greatly benefit us in terms of maintenance and code reuse. We currently use Newman CLI for our CI/CD integration, but it’s my understanding that the packages will only be supported in Postman CLI. This issue is the only thing holding us back from converting to Postman CLI from Newman.

1 Like