Postman API works only with X-Api-Key request header

Hello
My issue is that with the same API key, when I request /collections endpoint with X-Api-Key in the request header, it works like fine. but when I do with apiKey parameter
GET https://api.getpostman.com/collections/?apiKey=myAPIKey
It responds with a 401 “message”: “Invalid API Key. Every request requires a valid API Key to be sent.”.
I made my api key in collection variables to ensure it is the same. can anyone point me to the issue here please ?

Many thanks !

Hey @UAlee

Welcome to the community! :wave:

Have you tried the same request, with the Auth token in the URL but removing the trailing forward slash before the ?

Or going to the request settings and disabling the Cookie Jar?

Just trying the think or some different things to try :grin:

Hi @dannydainton
Thank you !
I tried that with https://api.getpostman.com/collections?apiKey={{apiKey}}
And disabled then enabled the cookie jar but in vain
I don’t think it is related to Postman client. I tried the request in browser and with vs rest client, always in vain :disappointed_relieved:

could you try to reproduce it please ?

btw, all of that to make your newman slack bot work with the Postman API :smiley:

Sorry @dannydainton or this disruption it is apikey not apiKey
that was driving me crazy :sweat_smile:

1 Like

I had literally just seen that and was about to reply :grin:

I went through one of my old projects and saw that it’s a lower case k

1 Like