Post request returns `411 Length Required`

Sending the POST request below returns 411 Length required in Postman desktop. It runs fine if I run it in my Terminal. It used to work in Postman.

What am I missing?

curl --location '' \
--header 'Authorization: XXXXX' \
--header 'X-Auth-Resource-Group: 9a6566da10fe448d9a093e61af45e674' \
--header 'Content-Type: application/json' \
--data '{
  "cosInstanceCRN": "crn:v1:bluemix:public:cloud-object-storage:global:a/0b5a00334eaf9eb9339d2ab48f7326b4:69284256-ead9-43f7-a069-4cf707c9f6cc::",
  "cseACLEnabled": true,
  "defaultWorkerPoolEntitlement": "cloud_pak",
  "disablePublicServiceEndpoint": false,
  "kubeVersion": "4.14_openshift",
  "name": "new-roks",
  "podSubnet": "",
  "provider": "vpc-gen2",
  "requestSecure": false,
  "serviceSubnet": "",
  "workerPool": {
    "diskEncryption": true,
    "flavor": "bx2.4x16",
    "name": "string",
    "vpcID": "r010-68dfdcd1-a8ca-4302-83a1-a14d7408ab7c",
    "workerCount": 2,
    "zones": [
        "id": "eu-de-1",
        "subnetID": "02b7-b2c7c714-2376-4f55-ba65-fd905eda89ec"

Environment: MacOS

Issue solved by checking the content-length in the hidden header :blush:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.