Output no longer displayed within Repeat loop

With Update 10.20, any Outputs within a Repeat loop are no longer displaying text

Below you can see the Request is Successful and a Body is returned, but Outputs are not displayed:

If you remove the Repeat link in the same flow, Output are displayed:

This behavior did not occur with v10.19

Hey @tbuck02 :wave:

Is this still an issue on the latest version?

@danny-dainton Yes. The screenshots I posted were from v10.20.7 I just checked for an updated version (there are none) and the verified the issue is still happening.

I reached out to the flows team and them haven’t been able to recreate the issue on the latest version. :cry:

I tried the same with a very basic example and the Output block is showing the data:

You tried the Clear cache and Reload option from the top level menu, to see if that helps here.

Without use recreating the Issue locally, it’s difficult to suggest what might be happening here. Does duplicating or created a fork of the Flow show the same issue?

  • “Clear Cache and Reload” did not resolve the issue.
  • Duplicating the Flow also results in the same issue of “Repeat Output not displayed”.

To recreate the issue you need to have Repeat and Collect blocks surrounding your Output. “Basic” Output does work & I was able to create a ‘workaround’ by disconnecting the Repeat block in my second screenshot (the highlight might be covering up that fact). If you run this Flow Snippet and add an Output between the Repeat & Collect blocks you should be able to easily recreate the issue I am seeing:
https://www.postman.com/postman/workspace/flows-snippets/flow/63b898822e67b05a8333e16c

NOTE: When performing multiple Repeats, only the last Output was displayed (as I would expect)

@danny-dainton so I create a fork from the “Repeat” snippet and I’m seeing what you are: the Output is functioning (on the WebOS version).

I tried running my own flows on the Web version and I am seeing zero Output. This is indeed confusing (and hard to replicate). I tried create a “fork” of one of my failing Flows and Output is still failing to appear.

@danny-dainton I did find a possible issue? if you have a Repeat=1 the number it is returning is 0 instead of 1:

If I run my Flow with Count=1 “RndNum” Output doesn’t display anything, but if I set Count=2 Then I get “RndNum” Output. The other outputs are still ‘empty’ though:

I’m seeing a similar issue with the For block followed by anything. (Send Request, Log, Output)

If you run this flow in the 10.20, the second request is called and shows in the console, but you don’t get a Success or Failure result in the block. (If I add a log or output after the For, nothing shows up.) And there’s no body. If you run it in 10.19, it runs as expected.

@spacecraft-astrona10 @tbuck02

I’ve been able to reproduce the issue with the output/log blocks not working in for/repeat loops when there is a send request block involved on the latest version of the app.

Our engineering team is looking into it.

1 Like

Hi, any workarounds for this issue?

I have unfortunately not found a way to work around the issue. I tried changing different Evaluate Blocks , Output, Log, etc. In addition, I had a previous flow that worked last Monday (2023-11-27), but has since not worked since upgrading to 10.20.7. It seems like as soon as you have a Repeat or For block, no collection tests run anymore (nor do the logs you write in the test output to the console), nor do you have access to the details of the request, if it was successful or not: ie

image

I reverted to 10.19.17 and am re-installing as necessary to avoid updating to 10.20.7.

any news about this bug?

@lunar-module-engine4

This was hotfixed. Please update to the latest version of the app.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.