OAuth 2.0 Authorization config - How to set the redirect_uri?

My question:
I’m trying to configure Authorization on a collection to use OAuth 2.0
I have all the configs set up under Configure New Token: Configuration Options.
However, “Callback URL” is greyed out and I can’t set that value.

The value I have set up in my app is “http://localhost:3000”, but the default value shown there is “https://oauth.pstmn.io/v1/browser-callback”. How do I set the redirect_uri?

Details (like screenshots):

If I then click “Get New Access Token”, a browser window opens to onelogin and it shows an error:

error: redirect_uri_mismatch

error_description: redirect_uri did not match any client’s registered redirect_uris

How I found the problem:
I was trying to set this up.

I’ve already tried:
I tried to include redirect_url=http://localhost:3000 in the Auth URL, but when I try to get the access token, it says I have a duplicate parameter.

I think you need to use the desktop app for this to work.

When I highlight that field I get, “The callback URL cannot be modified when authenticating via the browser”.

That worked! I hadn’t been using the desktop version, kind of forgot about it.

I will say that the error message is a bit deceptive, since if I AM using the browser version…it would seem like I would be authing via the browser.