Jenkins Console Output doesn't display the detailed test run

Jenkins console output displays just the SUCCESS/FAILURE message after the job is executed for the postman collection using newman. I would like the result to be displayed with more details with the test run like iterations, pass and fail status. any help would be appreciated!

However, I am getting the detailed result when i run the same newman command from Command Line.

Hey @kdenizfw :wave:

Welcome to the Postman Community! :postman:

Could you also include more details about the Jenkins job and the newman command that’s being run, please?

That console output feels more like something coming directly from Jenkins and nothing to do with newman running the Collection.

Hello,

When I run this command on cmd then it is works as it should. But I can not run it on Jenkins. I had the same issue once, I’ve searched and done so many things and I fixed. But I reset my computer and reinstalled Jenkins and now I am facing the same problem again.

the command:
newman run “https://api.getpostman.com/collections/33410737-79d75a4e-5733-49de-aaba-cdeab161c953?apikey=PMAK-65f9c844666c3100012a0475-209511012f550e4795709b40473d59ce0d” --environment “https://api.getpostman.com/environments/33410737-86a4a2bb-8fbb-4a2b-8e5e-5f85a674ecf4?apikey=PMAK-65f9c844666c3100012a0475-209511012f550e4795709b40473d59ce0d

I am expecting to work like this SS:

There’s a lot of Jenkins based environment information missing from this that without it, makes it difficult to point at what might be the problem.

Can you share more about that setup, how you’re configuring the job, which node version Jenkins is using, any screenshots or script snippets.

It is a freestyle project.-- Execute Shell
I hope these information works.

Jenkins Version: 2.440.1

image

image

Step 1:
I am creating a new item, freestyle project

Step 2:

Step 3:
What I expected to see:

What I see:

Has that ever worked in Jenkins? Do you know that Newman runs or is installed? Did you need to point to a global installation of that?

What is the output on newman -v? Does it show the version?

That SUCCESS message is coming from the Jenkins job which is outside on Newman.

Yes, this worked on Jenkins before because I changed some settings, I don’t remember the settings I made. And then I formatted the computer and it stopped working again.

Any newman command does not work through jenkins. I can only check it via “cmd”, I type “newman -v” and it shows “6.1.2” as version information.

The best thing is to not check anything against the cmd line for now and concentrate on getting the Jenkins config sorted, before you can think about running any newman commands.

I’m not going to pretend to know Jenkins and the way it should be setup, I have done this in the past but it was a long time ago.

I know that @vdespa has created great content around this subject a while ago and this video might help. It should play on the useful part for you at the moment:

1 Like

You are using shell in the config but are on Windows. Try selecting BAT (or similar).

I tried with “Windows batch command” and it worked. But I had to add these command "cd C:\Users\Acer\AppData\Roaming\npm\node_modules\newman\bin
node" before the “newman run”

I don’t wanna add more codes . I want to run on Execute Shell. There must be a way to do this because I’ve done this before.

image
The result on my computer:

in the video, the result:
image

I guess I could not explain my problem to you. Take a good look at the screenshots I sent you and I explain step by step;
1- Execute shell is selected
2- newman --version , node --version is typed
3- the project is run.
4- Expected result: writing newman and node versions (as in your video)
Actual result: newman and node versions are not written.