Help setting up interceptor for iphone and Windows 10


I am not exactly a stranger to using proxies, but forgive me all my experience - in addition to being over a year since I have used it, was with Portswigger Burp Pro, and I’m very disappointed with myself that I’m not easily making the jump.

I found this article in my research, and I really tried to get it to work, but I’m doing something wrong. I already downloaded the Postman app onto my computer so I’m not using just the Chrome extension.

So here’s my ipconfig /all -don’t worry, obviously I’ve obfuscated the actual ip numbers…

Never mind, I just learned that since I’m new, I am restricted to a single image upload. Very well then, I have lumped them all into one at the end.

And here’s screenshots of my iphone configuration screens, and I used the same fake IPs in the same places where I used the corresponding IPs to configure my settings.

The weird thing is, with iPhone, this may have changed recently, but you absolutely cannot just create a new wi-fi connection and just arbitrarily provide the IP address, subnet mask, router, dns, proxy, etc. What I ended up having to do is choose an existing wi-fi network that I already belong to and totally change all the settings. If you go in there and select “Choose a network” and choose “Other” you have to enter a name and choose a security type - those are the only things on that screen. Every security type requires a password except “None” and when you choose that, the “Join” option is the only thing available, and of course when you select it NOTHING HAPPENS. Fail.

So here are my configuration screens - I just took all the info I could from the above report, and stuck it where it seemed to belong. You can see where the numbers match up.
(Keep going, if you’re still interested.)

After configuring my phone this way, I was able to use the internet, but Postman interceptor was not intercepting any traffic. I tried a different configuration, replacing my internal wi-fi IP of with the outside world IP found by

But that was a bad idea.

I made sure my third-party VPN on my phone was off, what else could it be?

Any help is greatly appreciated! Thanks!

Hmm… are the outgoing requests made from your phone https? If so, make a call to some http website from Safari and see if Postman captures it?

Secondly, I am curious why are completely changing everything in your wifi settings? Just having your phone and computer on same network with the ability to talk to each other, just configuring proxy to your computer’s postman proxy port should do he trick.

@harryi3t @kamalaknn @SamvelRaja - thoughts?

Ah! Thank you for your reply, I forgot all about this, got sidetracked… My apologies!

I figured out what was wrong. I was overcomplicating things, as usual, lol, sorry! I don’t know why I thought I had to change all the IPs in my settings???

However, I discovered that either safari or https doesn’t play well at. all. with the proxy, why is that? Is there anything that can be done to mitigate that reaction? Since certs are free now, and easily available, http is considered bad practice and should be a thing of the past… it’s already a rare thing on the public internet.

Hi, I have similar issue, can able to connect internet via safari with same network, No history in Postman

Postman and Iphone are same Network and Port

Hey folks. I have not come across this. And just in general, all these Smart Devices, I absolutely do not understand this. And if you face the truth, now new and new gadgets, programs for phones and computers appear regularly. And it is very difficult to choose something because there is a choice and it is colossal. Found the 4Pro site recently. There are so many cool things, I would like to buy more than half of them all. LOL