Help needed , How do i run all collections in one Folder

I have four different collections testing different parts of the app in a single folder, anytime I tried to run it in native app collection runner, it only runs the very first collection in the folder and never runs the rest collections.

Would this be the case if implemented in CI/CD pipeline …

Thanks in advance for any help

Hey @ola100,

I’m not sure that I completely follow, would you be able to provide an example of what you’re seeing please?

Currently, The collection runner in the app will only run one collection at a time. If you’re using Newman in a CI pipeline you could create a script to run multiple collections.

If that’s what you’re trying to do?

@danny-dainton, thanks for your response , much appreciated

Yes I am trying to run multiple collections in a CI and could you please give me snippet of script to run multiple collections please.

I created collections to test different parts of the app and put all these different collections into one folder to serve has a smoke test for the app , and now wanting to put it in the jenkins CI pipeline


Any idea on how to go about it please

You could try something simple like this suggestion from @tmccann?

This could allow you to run multiple collection files with Newman.

@danny-dainton ,
thanks for your response , much appreciated ,

If you’d indulge me a bit more , am getting this issue when trying to run in newman in Jenkins pipeline but running fine when i run it locally on my system , below is the result on Jenkins :

`Building in workspace /Users/Shared/Jenkins/Home/workspace/test
[test] $ /bin/sh -xe /Users/Shared/Jenkins/tmp/

  • node --version
  • npm --version
  • newman --version
    /Users/Shared/Jenkins/tmp/ line 4: newman: command not found
    Build step ‘Execute shell’ marked build as failure
    Finished: FAILURE`

I am using macOS Mojave and newman is installed in my

which newman /usr/local/bin/newman

When I do npm install -g newman again , below is the response …

`/usr/local/bin/newman -> /usr/local/lib/node_modules/newman/bin/newman.js

  • newman@4.4.1

updated 2 packages in 2.384s`

please what am i doing wrong …