gRPC Using HTTPS Scheme


I am trying to make a gRPC request to my API which is behind a cloud load balancer. The cloud load balancer is a TCP load balancer that supports HTTP/2 but, for some reason which is beyond our control, rejects any requests that do not have a HTTP/HTTPS scheme. This is currently working for clients connecting from various languages (C++, Go, Python) so even though this is odd, gRPC is working.

When I manually overwrite the scheme in the Postman request path, postman gives me the error shown here

I cannot manually set the header in a gRPC request using Postman as the header tab is missing for this request type.

Is there a way to force postman to set the scheme to HTTPS for gRPC requests?


Hey @nkhumphreys7

Welcome to the Postman Community! :postman:

There’s no way to set the URL scheme (https) but a header can be set using the meta-data tab and TLS can be enabled using the lock icon toggle.

There’s no URL scheme other than grpc:// in gRPC.

Hi Daniel, thanks for the reply! Setting the header via the Meta Tab is doing exactly what we want! Thanks again!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.