Globals not seen


My question:
When I try to add a global under Environments, I can see the change there, but it is not added to URL’s when so requested. I have saved the global using the Save button in Environments → Globals, but the global is acting like it’s not defined.

In collections, if I mouseover a working global, I see the desired value - but if I mouseover a nonworking global, I see an empty string.

Details (like screenshots):

EG in:
…if I mouseover {{host}}, I see the protocol, hostname and port, but if I mouseover PIPELINE_ID, I see empty values.

I’m using Postman v10.9.3 - just upgraded this morning. The problem existed before the upgrade as well.

How I found the problem:
I tried to add a PIPELINE_ID global, and tried to use it.

I’ve already tried:
I’ve tried the save button, and I tried Command-S. I also tried exporting the globals as JSON; this appeared to work correctly.

Also, if I look at a URL in the Console, I see a bad URL that is missing PIPELINE_ID.

I googled about this for about a half hour, and found a couple of people on very old versions of Postman saying a Postman downgrade followed by a Postman upgrade solved the problem.


I removed two variables from Globals and added them to an Environment, and things started working. :slight_smile: