FQL query using a variable does not work


In an Evaluate block with input variables ‘content’ and ‘assetName’ (the latter set to “Core”), why does the first FQL query below work, while the second one using a variable yields null?



How can I get this query to work with a variable?

(2) [“ff32e03ab003”, null]

See also the flow in my public workspace: New Flow | Help | Postman API Network

Many thanks!

Have you tried using the “string” block to set the variable value instead?

Hi arlemi

Thanks for your reply. I’ve checked. It’s the same with a string block.

I tried a couple more things and couldn’t get that to work either. Looking at the docs I couldn’t find a way to do it either so I’m just assuming this isn’t something you can do in the Evaluate block. Let’s see if someone else has more info!

Thanks, Arlemi. I’ll move this topic to the Help category, as it doesn’t seem to be a beginner’s question anymore.

Good idea! Someone suggested using:

    $n := assetName;

which should give you the same result as content[primaryEntity.name=assetName].id.

This works. Many thanks for your help!

1 Like