Flow: Send Request observations

when opening today a flow which worked succesfully some weeks ago, I faced following challenges:

  1. the request did not run anymore, giving an unauthorized back even the collection itself run.

after some investigating on a new flow I saw that there normally is an environment that can be selected. but not on that specific block itself on the existing flow. after changing back and forth the linked collection somewhen it was possible to add an environment, strange.

  1. the collection uses two variables, but shows me three (one is not used in that collection and from another one)

sorry, but looks a bit shacky that all, isn’t it?

Hi @mischl !

Just to make sure i’m understanding your issue correctly:

  1. You had a flow that was working a few weeks ago
  2. It now gives you an unauthorized error when trying to run it, but the collection itself still runs fine
  3. Initially you were not able to select an environment on the Send Request block, but after changing the collection enough times you were able to eventually select one
  4. Now the Send Request block is showing you an additional variable from a different collection

Is that right?

Hi Daniel

Thank you for getting into that and detailed it out exactly.

  1. yes. and in my memorization it was without an environment setting in the send block (end of August), but not sure absolutely
  2. yes, was so until I fixed it
  3. exactly
  4. yes, and that additional environment variable is not used in that collection (on the screenshot on the left, right is it how it looks like when opening a new flow and assign the collection there)
  5. using another request from the same collection shows only that additional environment variable which is not used, but not the two really used (in collection authentication)

btw, it would be useful on environment and global variables to see where there a used/consumed currently. I had that in mind already before we talked now

are you able to access flows and collections when I share the id’s with you even when they are private for support?

Hi @mischl

Thank you for the clarification.

Regarding the viewing of private collections, no I cannot.

Can you try deleting the original Send Request block, quitting and re-opening the Postman app (or refreshing the browser) and then selecting the request from the collection again and let me know if the issue is still there? Also please check to make sure you’re on the latest version of the application if you are using the desktop app.

Thank you for your suggestion. We currently have a feature enhancement for adding the ability to see variable scope better in Flows, so it’s something we’re tracking.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.