Empty body after send request block

after the send request block, the request is correct all the test are passed but the outcome has blank body.

as you can see the request is correctly done and responde with the correct jwt as a login request, and the response has the correct body as it pass all the test that reads the json return of the called function. but in the log block (and also the eval block) it says that the body is completely blank. also watching the little tab when you pass the mouse on the Success() it says all test are passed but the body is blank.

iโ€™m using in the request varoius envirovment but iโ€™ve already tried to hard code the params, and also passing it as envirovment or passing it as a variable in flow nothing of this thing made a change in the way it works.

The way that this api work is a bit clunky and it could be also a problem of my infrastructure but i would know if there someone with similiar problem, or some easy solution that im missing.

Hey @giusmanzo !

Can you share a little bit more about the request being sent? Strange that it seems to execute the other functions and tests correctly but does not log anything.

Can you try running with another request just to demonstrate itโ€™s not an issue with your Flow?
Does this same thing happen when running the request through Postman normally?

The web service is not a proper api, i is a way to emulate the webserver using vbscript and asp pages. but in the return it should response with a json.
Using the request in the normal postman it work as normal and in the response is there with the correct body.

Iโ€™ve tried other request, the request of the same webservice have the same behaviors. iโ€™ve tried at request a the postman-echo api and worked normal with the correct body

Iโ€™m not sure what could be the problem here. I would suggest opening a ticket with support and someone from the proper team would be able to investigate better.

1 Like