Collection fails with newman but works fine on Postman runner

Your question may already have an answer on the community forum. Please search for related topics, and then read through the guidelines before creating a new topic.

Here’s an outline with best practices for making your inquiry.

The collection that’s being used stopped working with newman one unfortunate day. This was all working fine till that day but now its not working anymore and failing with JSON error

Details (like screenshots):
Using docker to run these collections:

docker run -v {PATH_TO_COLLECTION}:/etc/newman postman/newman:5.1 run “{MODULE}.postman_collection.json” - --environment=“ENV.postman_environment.json” --verbose --reporters=“json,cli” --reporter-json-export=“newman-results.json”

How I found the problem:
One fine day the Jenkins job started failing and sending chat msgs

I’ve already tried:
Have tried with latest postman/newman image but no help. The same collection works fine in runner. Wondering how this stopped working all of a sudden.

Note: Have already looked at the similar posts regarding this in the community but no help

Welcome to the community :smiley:

Which Json version are you using, there is change in collection Json version try using migration tools or export Json file again . Else add more details of the error so that we could look into it

Did some digging into the issue and it came out with client side cookie that needed to be set auth token. It got resolved. Thanks for a quick look into this :slight_smile:

1 Like