Checkbox Autenthication via Browser in OAut2 missing

My question: I am using postman via webfrontend (no local installation) and want to use an OAuth2 access. This is not working due to the fact that I cant change the callback URL and I dont have the Checkbox “use authentication via browser” (=> and this is the most often cited problem solution).

Details (like screenshots):

How I found the problem: Using OAuth2 failed

I’ve already tried: I found nothing in FAQ and google, stackoverflow, … except the hint to “check authentication via browser”