401 Error on CRUD ops

I am trying to test my CRUD ops and I keep getting a 401 error. There is no security of any kind in my program at this point. It doesn’t matter what CRUD command I use, I get the same 401 error. I have tried Postman Desktop, I have tried clearing my cache, I have tried Google. I have no idea what is going on or why. Any help is appreciated.

Response codes are the responsibility of your API. Something in your code is causing it to return a 401.

It is possible whatever API Gateway you’re using is causing the 401 to be returned. How are you deploying your API?

I am using SpringTool 4. I am a student working on a group project. I have one model, one controller, and one repository so far. I based my code on a practice project provided by my instructor. The practice project works in Postman like it’s supposed to. I’ve compaired side by side my code and the practice project and, other than changing the names, the rest of it is the same from the imports on.

Are you sure the url of your project is correct? Are you running the API locally or is it deployed somewhere?