Write Responses To File PDF example Not Working

So the question has been asked a few times, but I have tried all the documentation regarding Write Responses To File, testing with dummy requests, and my team is getting the same error listed in

Does anyone have any help that they can give on this? For this, we have an API endpoint that will give us a binary or PDF conversion of the output much like Dummy Request 1. The Write Responses To File collection postscript works and will export the JSON. The issue seems to be trying to get it to save as a pdf in Dummy Request 1. Looking at my terminal when the postscript runs from Dummy Request 1, I see the following Error [ERR_INVALID_ARG_TYPE]: The β€œdata” argument must be of type string or an instance of Buffer, TypedArray, or DataView. Received undefined. Dummy Request 2 has an output.

Can anyone assist on getting Dummy Request 1 working as the URL may no longer point to a valid PDF anymore. Despite that, the case linked above using the same tools also has the same issue on their end, specifically around PDF being written to the local server.