Valentino Coffee API Assignment #5 Issue

Hello All,

Please I need a help concerning my assignment #5 as I’m getting this error after including my API Key correctly
'AssertionError: expected ‘\n\n\n\n\n\n\n<html\n …’ to include ‘postman login --with-api-key’

Meanwhile, my test passed on my remote repo.

Hey @tyexcel :wave:

It looks like you might have copied some extra new line characters and some html tags into that field.

I would check that text field again.

Thanks @danny-dainton for your reply.

Please what text field do you suggest I check.


The field that you included your API Key correctly in. You can see from the assertion message that it’s also included some extra characters, maybe fro you copy and pasting that from a different place.

Thanks for your assistance.

I think I’d be able to revisit the issue maybe next month as it seems I’ve reached my usage limit

You’re using the Web version with the Cloud Agent so that has a limited amount of calls each month (1000 a month).

You can either download the Desktop Agent from here:

There no limits on this or you can download and use the full Desktop Client version of Postman. This can be downloaded from the same link above.

1 Like

Hi @danny-dainton, I have tried what you suggested and I’m still getting an error. I even tried generating a new API key few times, copied and pasted it while making sure there was no space included but unsuccessful. Is there any other way I should try? Many thanks,

Hi @vicki-apitest.

Can you follow the instructions on this page. Specifically, I want you to use the collection runner to generate an API key by selecting the ‘Automate runs via CLI’ option. Here, you can automatically generate the full code which includes a valid API key and copy and paste that on your command line.

Hi @gbadebo-bello , I have tried what you suggested but I’m still getting errors. I even tried starting from the scratch, recreating a repository and setting a secret for the API key. I’ve watched the clip and followed the instruction very carefully but I’m still getting the errors. Please help. Many thanks,

Can you share a link to your Public Workspace and the Public Github Repo, please?

It will be easier to see what’s happening in there, than trying to describe it.

Just found out what was triggering the issue. All sorted now. Thanks!

Do you want to share what that issue was just incase it might help others in the future?

I was mainly focused on troubleshooting the issue, assuming it was related to the API. However, it turned out that the problem was with the URL/link of my project. After carefully going through the console. I duplicated the section that was already mentioned in the script. Hope it helps anyone that’s facing the same issue =)

After completing the ‘Postman API Automation for Beginners’ course, what’s the next step for someone who’s started learning Postman? Any suggestions would be appreciated.

We have a number of different courses available for you:

We also have the Postman Academy which offers various courses:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.