Schedule running without monitor (Error: getaddrinfo ENOTFOUND)


This is my first experience with Postman. I created a Collection that works correctly in Collection Runner,

but when I want to schedule it and run in the monitor, it shows me an error:

Error: getaddrinfo ENOTFOUND.

I think the reason is that it works only in local network and IP address isn’t public. Is there any workaround to schedule collection running or should I simply change some network settings?

Best regards,


Hi @Cziru
Welcome to the community :wave:

Yes, Monitors require all URLs to be publicly available on the internet as they run in the Postman cloud. A monitor cannot directly access your localhost or run requests behind a firewall. However, to overcome this issue, static IPs are available for certain plan types.

Refer to this section here for FAQs on monitors.

Thanks for your answer! I do it via Jenkins.