Private mock server returning 403 response

I have a private mock server setup and i’m able to send a request and receive my 403 response body schema, but I’m not sure why the 403 is being returned.

I’m using a GET call with no parameters, no oAuth or security mechanism and I have the x-api-key header with my postman api key.

Details (like screenshots):

Hi @jeremyfiel

Has your API key expired?
or have you tried regenerating a new one?

nope, i just generated it and tested it immediately and it returned 403.

Yes, I tried a second one and same results

Where does it get the 403 response body from?
is that an example you have created?

Do you have multiple example files for this endpoint?
(if so what example files have you setup)

the 403 is my own schema example provided in the definition

i have examples for each response code. the example isn’t the problem, I can’t get it to return 200, either with an empty body or with the example schema I have

When you say ‘Mock Server’ are you referring to the ‘Mock Server’ tab or the API tab?

Sounds like you mean the API tab… I haven’t used that much personally, but I would guess that a 403 would be related to having the correct access to the URL used in the schema.

I have a mock server associated to a collection. the collection was generated from an imported openapi definition. So I have a collection, api and mock server in postman.

I tried sending the request outside of our corporate network and I’m getting the same 403 response.