Postman works in localhost but not in production

I’m coding an API on a Symfony 5 project.
My requests works fine on my localhost server (GET and POST methods) but not on the production serveur.
I’ve tried a GET method URL on my production server, directly on url bar of Chrome browser, and It works fine.
I’m getting mad.
Does anyone can help me please ?

Hi @infoprogis

Are you able to provide more information about what you have tried?
Maybe screenshots and logs?

Thanks W4dd325 for your answer.
I can give you a simple GET query exemple. It returns a people list.
On my localhost server it works with Postman

In prod mode (same code but different server and DB) it works fine if I enter the API url in chrome

but not with postman

I don’t even understand where this error page come from… It seems to come from another website.

Use the capture requests feature with the Chrome Plugin\Interceptor.

Then try the get request in the browser and check the working request that gets recorded in Postman against your console log for the failed request.

Check the request and response, the body, the headers, etc. Make sure its actually setting any variables that you have in the request.

Hopefully you will find that something is different between the two requests that will help pin point the issue.

At a high level, that error is telling you that its hitting the server but can’t find the page rather than an authentication issue.

You really ought to parameterise your URL and passwords into environment variables.

Is your prod server using standard ports for https? 443?

Yes, the server uses the 443 port for https.
In the Postman’s console I noticed this warning : Hostname/IP does not match certificate’s altnames
Maybe a DNS configuration ?

If I activate SSL verification I got this error : Error: Hostname/IP does not match certificate’s altnames: Host: is not in the cert’s altnames:,,,,,,,


Did you try and Google the error?

First hit I found advises to turn off SSL certificate verification.